About the General category

Need help with Mantid, ask here. And other general discussion.

I installed mantid on a new laptop (running windows 10). When I try to run either Mantid plot or Mantid Workbench, I get an error message!

I tried uninstalling and re-installing, also tried to run as administrator etc. but that did not help.

Any suggestions are welcome.


Hi, I’ll run you through our troubleshooting steps!
In a command prompt can you try to launch with:


If this does not work, try launching with:

cd C:\MantidInstall\bin set QT_PLUGIN_PATH=%CD%\..\plugins\qt5 export 
PYTHONPATH=%CD%;%PYTHONPATH% python -m workbench.app.main

Do either of these work?


The first command did not work as such an exe or bat file is not there in that directory.
The second command (everything in one line without the linebreak) was executed but that did not help run mantid.

BUT…in the meanwhile the following was suggested by Andrew Lim (through Pabitra Biswas) and that worked!

thanks for your help.

Avinash Mahajan

They could try adding

UpdateInstrumentDefinitions.OnStartup = 0

CheckMantidVersion.OnStartup = 0

usagereports.enabled = 0

to the C:\MantidInstall\bin\Mantid.user.properties to and then try to start mantid.