Binning multiple Q ranges

Attempting to reduce data in multiple Q bins from SANS2D and using the exact user file commands (under “L”)

Keep receiving the same ValueError

ValueError: Invalid value for property OutputBinning (dbl list) " 0.005,0.1,0.03,0.08,1.0 [/LOG]]": Could not set property OutputBinning. Can not convert " 0.005,0.1,0.03,0.08,1.0 [/LOG]]" to dbl list

at line 50 in ‘<Interface>’

caused by line 463 in ‘C:/MantidInstall/scripts/SANS\’

caused by line 731 in ‘C:/MantidInstall/scripts/SANS\’

caused by line 727 in ‘C:/MantidInstall/scripts/SANS\’

caused by line 531 in ‘C:/MantidInstall/scripts/SANS\’

caused by line 2764 in ‘C:/MantidInstall/scripts/SANS\’

caused by line 1094 in ‘C:\MantidInstall\bin\mantid\’

caused by line 1032 in ‘C:\MantidInstall\bin\mantid\’

caused by line 1016 in ‘C:\MantidInstall\bin\mantid\’

when attempting to use the “/LOG” term despite where this appears. If i remove it, the data reduces but only bins in linear spacings.

Any help here would be much appreciated!

Hi, just looking into this issue for you.
Can I just confirm whether you see this issue as soon as you try to load the user file, or when you attempt to process the data?


It crops up after attempting to 1D reduce, the user file loads file.



Can I ask:

  1. What is the version number and the release date for the Mantid you are using? (Main MantidPlot window → Help → About MantidPlot)
    2a. Is the exact line in your user file “L/Q 0.005,0.1,0.03,0.08,1.0 [/LOG]]”?
    2b. If it is, does “L/Q 0.005,0.1,0.03,0.08,1.0 /LOG” throw an issue?

Mantid is 3.13.0 and released on 24/07/18

I have tried all variations of adding /log - in square brackets, at the end of the line, or next to the dq parts. Whenever ‘/log’ or some string is present it throws up the error, whereas if I leave it out there is no error. The issue is that the default if i leave it out is to bin the data in linear steps not logarithmic steps.

Can I just get you to try changing the step sizes to negative values: “L/Q 0.005,-0.1,0.03,-0.08,1.0” would be your new string (under the hood, negative steps should be interpreted as logarithmic).

When I run this I don’t get an error, so if you can just check you get the output you expect.


I don’t get the error either and works as expected! Thanks Tom, much appreciated!