Building Mantid on Windows cmake cannot find Lib3mf

Hi I am trying to build Mantidworkbench on Windows 10x64.
I followed the getting started guide, I am using cmake 3.20.5.
But I get an error message, that Lib3mf cannot be found.
I tried to give the path to it manually in cmake gui, but this did not work.
Any idea how I can fix this?

CMake Error at C:/Program Files/CMake/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
Could NOT find Lib3mf (missing: LIB3MF_INCLUDE_DIR)
Call Stack (most recent call first):
C:/Program Files/CMake/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
buildconfig/CMake/FindLib3mf.cmake:21 (find_package_handle_standard_args)
Framework/DataHandling/CMakeLists.txt:646 (find_package)

Hi Thomas,

Out of interest are you building from the latest master on GitHub?
You could set DENABLE_LIB3MF=OFF in the Cmake gui and see if it still builds successfully?

I believe Lib3MF is only used for loading mesh files of Sample Shapes for absorption corrections, so you may not need it enabled. Tell me how you get on!

Dear Daniel, thanks for your help.
I am using the latest master from github. I also tried it out on a different computer today with the same problem.
I tried to set DENABLE_LIB3MF=OFF and ENABLE_LIB3MF=OFF (guess the D was a typo), but this seems to have no effect at all.
But I found out why manual setting the path did not work. I set the wrong path.
I tried setting it to: /external/src/ThirdParty/include/lib3mf
But it should only be set to: /external/src/ThirdParty/include
With that everything works.
It is really amazing how easy it is to build mantid, I have never build anything before on windows.

Well done for figuring this out! The path should be automatically set-up and you found a bug in our code, so thanks for that! I believe the fix is up and should be merged in a few working days.

Hmm, that’s odd that setting ENABLE_LIB3MF=OFF didn’t work.