Catalina issues

Hi all, I’m running macOS, recently upgraded to 10.15.5 (catalina). I’m having some issues with permissions for reading files from within workbench. Here’s an example entered in the IPython window:

PermissionError                           Traceback (most recent call last)
<ipython-input-4-d7f5deaa718a> in <module>
----> 1 open('/Users/malcolmguthrie/Documents/SNAP/ipts22004/sims/snap46756.pks','r')

PermissionError: [Errno 1] Operation not permitted: '/Users/malcolmguthrie/Documents/SNAP/ipts22004/sims/snap46756.pks'

The same command works fine from normal python3 instance run from terminal.

I know that Catalina messed with permissions, so I went to preferences/Security & Privacy/Files and folders/ and indeed, workbench was not there. The ability to add it was also greyed-out. After more googling, I went to “Full Disk Access” and was able to grant this to workbench (it previously did not have this privilege):

I hoped this would fix it, but I’m still getting the same error and out of ideas now.

Any mac guru’s who can help!?


I have another datapoint: I tried the same operation using workbench installed on the SNS analysis cluster. It worked absolutely fine. To me, this is confirmation that it’s a MacOS issue.

What version were you before upgrading to 10.15.5? I’m on 10.15.4 and don’t have anything like these permissions problems, and my full disk access list is empty.

Hi Daniel, I’m sorry, I don’t have a record of that. Although I’ve been using workbench successfully for a while (since last OS upgrade), and only encountered this particular problem this morning. I’m happy to do any other troubleshooting. Of course, I also checked the permissions on the file I’m trying to read, they look fine: -rw-r–r-- . I’d be very happy to try any troubleshooting you can suggest…

Hi Malcolm, I upgraded to 10.15.5 and I don’t see this permissions problem! Is it possible that your facility has added permissions to your data or has set-up your Mac in a certain way to cause this?
You could try launching Workbench from the terminal with: /Applications/
and see if this problem still exists. If so send any useful output to the terminal!

I tried opening workbench from terminal and…

The problem didn’t happen, can open the file with no permissions error.

I subsequently killed workbench and re-opened by clicking on the app in the dock: the error re-appeared.

So, I’m no closer to explaining this, but it seems I have a workaround for my immediate issue (i.e. open workbench from terminal!). Thanks!

1 Like