Compiling the framework on ARCH

I would like to use the Mantid python API for a project and I’m trying to compile the Framework only on an up-to-date ARCH LINUX installation.

I had to add -lgsl -lgslcblas -lm to the link.txt of the kernel to avoid things like:

mantid-3.10.1-Source/debug/bin/ undefined symbol: gsl_qrng_sobol

when importing things into python, but after quite some poking in the builds I can now

cmake Framework


make -j8 PythonInterface

with a number of warnings but no errors.

However, trying to

from mantid.simpleapi import *

results in: undefined symbol: _ZN3tbb8internal23allocate_via_handler_v3Em

This seems to be related to the (non?)linked libtbb or maybe even libstdc. I get the same error when using the binaries in the mantid_3.10.1-0ubuntu1~xenial1_amd64.deb package.
The same error I also see when using the mantidpython interface.

Can anyone help me with this?

Hi. We just released v3.11.0 which has fixes in it for newer versions of gsl and boost. You can install mantid from the AUR, I just bumped the version.

We also have pre-compiled nightly packages for Arch which can be found here.