Error: 'Bad Quality package' while installation in Ubuntu 14.04

I have an old package of mantid (v. 3.9.0), I am having trouble to update this to the latest version. While trying to update the mantid package via apt, I get the following error message when I am trying the wget

wget --proxy-user=harishs --proxy-password=fail+Word+92 -O - | sudo apt-key add -
–2018-03-16 10:54:39--
Connecting to… connected.
Proxy request sent, awaiting response… 403 Forbidden
2018-03-16 10:54:39 ERROR 403: Forbidden.

gpg: no valid OpenPGP data found.

Another method I tried was to download the Debian file and install it through Software Centre, but it shows an error message saying ‘Bad Quality package’ error. Although, I can install the ‘.deb’ file by running dpkg, I am concerned that it might break some functionalities in my OS.


Sorry your having issues with this.

From the error above it suggests that the wget failed because of the proxy server and could not provide the data to apt-key-add. What does wget --quiet --proxy-user=harishs --proxy-password=*** -O - give you. It should give:



If you can’t get the wget coomand to work then you can paste the above content into a file, key.asc, and run sudo apt-add-key key.asc.

The tool we use to create our debian packages unfortunately has some known issues with older versions so these warnings are expected but can be ignored safely.


This shows no messages, does it mean the key is added? Nevertheless, while trying to upgrade it with apt-get fails once again:

> harish@harish-desktop:~$ sudo apt-get install mantid
> Reading package lists... Done
> Building dependency tree       
> Reading state information... Done
> The following extra packages will be installed:
>   librdkafka++1 librdkafka1
> The following NEW packages will be installed:
>   librdkafka++1 librdkafka1
> The following packages will be upgraded:
>   mantid
> 1 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
> Need to get 230 MB/230 MB of archives.
> After this operation, 14.5 MB of additional disk space will be used.
> Do you want to continue? [Y/n] y
> WARNING: The following packages cannot be authenticated!
>   mantid
> Install these packages without verification? [y/N] y
> Err trusty/main mantid amd64 3.11.0
>   403  Forbidden
> W: Duplicate sources.list entry trusty/main amd64 Packages (/var/lib/apt/lists/
> W: You may want to run apt-get update to correct these problems
> E: Failed to fetch  403  Forbidden
> E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

PS: I removed :// after every http, since I can’t post links being a new user. I also tried adding the key manually and tried updating and installing, still doesn’t work, it pops up the same error.

I would have expected that to output the block of text I posted above and not nothing. It looks like you have a proxy that might be causing an issue for some reason. Could you try running curl -v -U user:pass -x proxy:port --url where you relace user:pass with your proxy login and proxy:port with your proxy address and port and see what happens?

But even adding the key manually (as you had suggest right below that) and trying to install doesn’t work

I don’t think the key has been added given the warning from apt install. I was hoping to get more verbose detail from that last curl command on the error it is running into.

The other option here is to go with the graphical based installer and ignore the warnings as it is installing the same package.

* Hostname was NOT found in DNS cache
*   Trying
* Connected to ( port 8080 (#0)
* Proxy auth using Basic with user 'harishs'
> GET HTTP/1.1
> Proxy-Authorization: Basic aGFyaXNoczpmYWlsK1dvcmQrOTI=
> User-Agent: curl/7.35.0
> Host:
> Accept: */*
> Proxy-Connection: Keep-Alive
< HTTP/1.1 403 Forbidden
* Server squid is not blacklisted
< Server: squid
< Mime-Version: 1.0
< Date: Fri, 16 Mar 2018 10:20:30 GMT
< Content-Type: text/html
< Content-Length: 3275
< X-Squid-Error: ERR_ACCESS_DENIED 0
< X-Cache: MISS from none
< Via: 1.1 none (squid)
< Connection: keep-alive
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>ERROR: The requested URL could not be retrieved</title>
<style type="text/css"><!--
 Stylesheet for Squid Error pages
 Adapted from design by Free CSS Templates
 Released for free under a Creative Commons Attribution 2.5 License

/* Page basics */
* {
	font-family: verdana, sans-serif;

html body {
	margin: 0;
	padding: 0;
	background: #efefef;
	font-size: 12px;
	color: #1e1e1e;

/* Page displayed title area */
#titles {
	margin-left: 15px;
	padding: 10px;
	padding-left: 100px;
	background: url('') no-repeat left;

/* initial title */
#titles h1 {
	color: #000000;
#titles h2 {
	color: #000000;

/* special event: FTP success page titles */
#titles ftpsuccess {

/* Page displayed body content area */
#content {
	padding: 10px;
	background: #ffffff;

/* General text */
p {

/* error brief description */
#error p {

/* some data which may have caused the problem */
#data {

/* the error message received from the system or other software */
#sysmsg {

pre {

/* special event: FTP / Gopher directory listing */
#dirmsg {
    font-family: courier;
    color: black;
    font-size: 10pt;
#dirlisting {
    margin-left: 2%;
    margin-right: 2%;
#dirlisting tr.entry td.icon,td.filename,td.size, {
    border-bottom: groove;
#dirlisting td.size {
    width: 50px;
    text-align: right;
    padding-right: 5px;

/* horizontal lines */
hr {
	margin: 0;

/* page displayed footer area */
#footer {
	font-size: 9px;
	padding-left: 10px;

:lang(fa) { direction: rtl; font-size: 100%; font-family: Tahoma, Roya, sans-serif; float: right; }
:lang(he) { direction: rtl; }
</head><body id=ERR_ACCESS_DENIED>
<div id="titles">
<h2>The requested URL could not be retrieved</h2>

<div id="content">
<p>The following error was encountered while trying to retrieve the URL: <a href=""></a></p>

<blockquote id="error">
<p><b>Access Denied.</b></p>

<p>Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.</p>

<p>Your cache administrator is <a href="mailto:webmaster?subject=CacheErrorInfo%20-%20ERR_ACCESS_DENIED&amp;body=CacheHost%3A%20none%0D%0AErrPage%3A%20ERR_ACCESS_DENIED%0D%0AErr%3A%20%5Bnone%5D%0D%0ATimeStamp%3A%20Fri,%2016%20Mar%202018%2010%*%2F*%0D%0AProxy-Connection%3A%20Keep-Alive%0D%0A%0D%0A%0D%0A">webmaster</a>.</p>

<div id="footer">
<p>Generated Fri, 16 Mar 2018 10:20:30 GMT by none (squid)</p>
* Connection #0 to host left intact

The error message at the bottom seems to suggest an access control problem by the service provider. I’ve tried this from RAL and someone from ILL has also tried without error. Would you be able to contact your network administrator as it looks like something is blocking it at your end?

Ok, I will try to contact them and let you know. Thank you, meanwhile, Will it be fine if I install using the Debian file by ignoring the error messages?

It will be fine to ignore the messages. That is what will happen if you install on the command line anyway.