Installation Problem on Windows

I downloaded Mantid onto windows but when I try to open Mantid Workbench it gives me an error saying ‘Python has stopped working. A problem caused the program to stop working correctly.’ And then it comes up with the Mantid error report but won’t let me send any information off.
I am using a personal STFC computer and I know someone else who had this problem. But I also had a similar problem on my old laptop.

However, when I just tried to re-install it just now it stopped half way through the installation and gave me this ‘Error opening file for writing: C:\MantidInstall\bin\python Click Abort to stop the installation, Retry to try again, or Ignore to skip this file.’

Hope you can help and thanks!

Can you try to open, and create an Error Reporter. Then post the error message you get when the error report fails to send! That’d be great to have.

Out of interest, what version of Mantid are you installing (e.g. version 6.0) ?
If you want to try a reinstall then please empty the MantidInstall directory and delete it before trying to install again. I assume that a reinstall won’t fix the problem with opening Mantid Workbench, so feel free to try the instructions below first:

  1. Firstly, open the user properties file in any text editor. The file will be in the install directory, something like: C:\MantidInstallNightly\bin\

    Then add these 4 lines to the end of the file:

    UpdateInstrumentDefinitions.OnStartup = 0
    CheckMantidVersion.OnStartup = 0
    usagereports.enabled = 0

    Save the file and try to open workbench.

  2. If that didn’t work, try launching from a command prompt: C:\MantidInstallNightly\bin\MantidWorkbench

  3. The next thing to try is:

    cd C:\MantidInstallNightly\bin
    set QT_PLUGIN_PATH=%CD%\..\plugins\qt5
    python -m

Tell me if these do not work and we can try some more things!

Thank you Daniel! Option number one seems to have done the trick!
This is the original error message if anyone else gets the same error:

These are the further details upon trying to debug it in visual studio:

I’m glad it worked Katie!

In some cases after “fixing” Mantid Workbench by adding 4 these lines and launching successfully, some users have found that removing those 4 lines doesn’t “break” it again, and they can still launch Workbench successfully. If you have a minute to try removing these new lines and relaunching Workbench to let me know, that’d be great! It is better to not use these 4 lines, so if Workbench does still open for you then remove them! :slight_smile:


Hi Daniel,

I tried removing the lines and it didn’t work again so I had to add them back in again.
And also I realised I didn’t say which version I was using. It’s the 6.0.0… but I think I had a similar problem when I tried to download an earlier version.

Cheers, Katie

Thank you for checking! Really good to know!