Mantid 3.5 Windows Installation

We’d like to apologise for a minor issue in the installer for Mantid 3.5 on the windows OS. You may find that Mantid fails to start up correctly if you start it from the shortcut attached to the task launcher. The fix is simply to delete the existing launcher and drag a new one in from the the desktop.

See the mention of this in the release notes

I just installed mantid on a win7 64 bit computer. When I try to run mantid, i get an error saying “MantidPlot.exe has stopped working”. I tried advice of deleting the existing launcher and dragging a new one in from the desktop. This did not work. Is there more advice?


Hi Xthought,

Did you install Mantid 3.6 or a nightly build? Does the error you see appear immediately on launching Mantid or do you see anything happen first?


Thanks, I installed matid 3.6.0. Upon launching (from start menu or desktop shortcut) the Mantid launch splash pops up (showing release date & version #). A few seconds later, the the error message appears.
Thanks, Again

Thanks for the info. There’s a script in the MantidInstall\bin folder (where MantidInstall is the folder you installed to) called mantid_reset_settings.bat which clears various settings - does running this help?

No, Unfortunately that did not fix it. I ran mantid_reset_settings.bat from the folder and from elevated prompt. In both cases I saw “Qt preferences cleared”. But I am still getting the same behavior. Thanks for the feedback.

Another possibility could be that the PYTHONPATH environment variable isn’t set right, or that there’s another version of Python that Mantid is finding instead - could this be the case?

Hi Tom,
I thought Mantid installed/used its own version of python??? I do have anaconda installed in the directory C:\Anaconda2 . Thanks for any advice!

Hi Again, Tom
OK… I am running win 7 32-bit. I think this is the problem?? Is there a way to get 32 bit version of mantid? Thanks?

Unfortunately we don’t support 32-bit Windows any more, the package is built for the 64-bit OS so it is likely this is the problem.
Regarding the python versions, Mantid does come with its own version of Python but if it is finding another version then it might need to be moved earlier in the PATH.