Mantid fresh install does not start on Windows

I downloaded the windows package from here:
Installation runs without issues and ends normally, but the program does not start. I get the error message attached on screen.


The first thing to try is editing the user properties file:

  • Open the file C:\MantidInstall\bin\ in any text editor (such as Notepad).
  • Add these 3 lines to the end of the file.
UpdateInstrumentDefinitions.OnStartup = 0
CheckMantidVersion.OnStartup = 0
usagereports.enabled = 0
  • Save the file and try to open MantidWorkbench again.
  • If Mantid still does not open, then add this fourth line to the file


  • Again save the file and try to open MantidWorkbench

Tell me if these steps work for you or not. There are plenty more steps we can try!

The first three lines solved the problem.

1 Like

Glad it worked and thanks for that info!

Hi Daniel - I’m now having this issue with the latest Nightly build on a new windows machine. The first three lines above fix the problem, but I’m now concerned that the instrument definitions etc won’t be updated correctly on startup. I’m not really sure why a fresh install of this software shouldn’t work out of the box. The machine has had nothing else done to it, so it is entirely the fault of the software…

Hi Chris, I agree this would be a great problem for us to solve! These checks that the lines above disable are the only points in our launch script where we try to connect to the internet. As these checks work in most cases, but sadly not for some on Windows, the problem is likely something subtle. The instrument definition line is simply running the DownloadInstrument algorithm which you could run manually.

Out of interest, now you can open Workbench with these 3 lines in the properties file, can you remove say the UpdateInstrumentDefinition line, save the properties file and see if Workbench will in fact still open successfully??

Hi Daniel - after removing the UpdateInstrumentDefinition, workbench no longer opens. It doesn’t appear to `crash’ with the error log window as before, it simply stops loading.

Thank you for checking this! @ChrisR Very useful info!

@ChrisR - are you able to run the DownloadInstrument algorithm manually?

@thomashampson I will let you know when I get to the point of being willing to let Mantid crash on me :slight_smile: