Problem in installing Mantid environment on Windows

Hello, I installed Anaconda3 (Ver. 2021.05, Python 3.8.8 64bit) and tried to install Mantid package using conda command but failed. The information is as below:

(base) PS C:\Windows\system32>  conda install -c mantid mantid
Collecting package metadata (current_repodata.json): done
Solving environment: /
The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:

  - <unknown>/linux-64::mantid==6.5.0=py38hea6597a_0
failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: |
The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:

  - <unknown>/linux-64::mantid==6.5.0=py38hea6597a_0
failed with initial frozen solve. Retrying with flexible solve.
Solving environment: /
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

(base) PS C:\Windows\system32>

I also tried other Anaconda versions, but failed again.
I just want to know how to use Mantid package on Windows without Mantid Workbench.
Thanks.

Hi,

It looks like you are trying to install mantid into your base conda environment. You will need to create a new conda enviornment and activate it before installing mantid. e.g:

conda create -n mantid_env
conda activate mantid_env
conda install -c mantid mantid

where mantid_env is the name of your new conda environment.

Thanks,
Tom

Hi, Tom. Thank you for your reply. I created a new conda environment and tried to install Mantid, but failed again.

(base) PS C:\Windows\system32> conda activate mantid_env
(mantid_env) PS C:\Windows\system32> conda install -c mantid mantid
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: \
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
                                                                                                                       |failed

UnsatisfiableError:

(mantid_env) PS C:\Windows\system32>

Hi,

Can you update your Conda with:

conda update conda

and try again? It worked for me after Conda updates to version 22.11.1, otherwise I think I was having the same problem as you.

Thanks,
Tom

Hi, Tom. Thank you very much for your replies. I tried again and failed. Maybe there are some problems in my Windows. I have given up to install Mantid environment in Windows and I am using a Linux system in a virtual machine instead.
Thanks again.
Haichuan

Hi Haichuan,

Sorry to hear that you’re still having trouble installing Mantid into a Conda environment. If you wanted to attempt to use Windows again, we have found that mamba (download and install mambaforge here) is a lot faster and more reliable when attempting to resolve all of the dependencies.

Thanks,
Tom