Problem with data reduction of multiple runs

I am trying to reduce data from an ILL measurement, using a script that worked on the ILL machines. However, when I run it on my work computer I keep getting the error message:
Invalid value for property Run (list of str lists) from string “xxx:xxx.nxs”: When setting value of property “Slave”: File “xxx:xxx.nxs” not found

Where xxx are my entered run numbers.
The input looks as follows:
ws = mtd.IndirectILLReductionFWS( Run = ‘xxx:xxx’ + ‘.nxs’, MapFile = ‘file.xml’)

Which is consisten with the notation provided here(MultipleFileProperty)

When I run the script with a single run number e.g.
ws = mtd.IndirectILLReductionFWS( Run = ‘xxx’ + ‘.nxs’, MapFile = ‘file.xml’)
the data reduction works fine.

I suspect the problem is my local environment, either with the python packages or my mantid version, as the script worked fine at the beam-line. Does anybody have an idea, where my problem could be? I am using mantid 4.2.0. on a windows machine.

I too had this problem and spent a long time with my ILL contact trying to sort it out. In my case the problem was a space in the directory/folder name!

Thanks for the feedback, unfortunately this seems not to be the case for me, as I have no empty spaces in my folder names.

You can also do data reduction of IN16B using the Mantid Indirect>Data Reduction interface. If you set your defaults to ILL & IN16B the gui will be set up to run.

In that case it is probably an odd character in the full path name.

If you could send a couple of nXs raw data files to I could try it out. I did that for an user last week!

1 Like

Using the GUI works, so I will be doing this for the moment, rather than scripting it. As I did the majority of the data reduction already during the beam time, this solution should suffice.
I appreciate your input, thank you very much.