Trouble accessing data archive

I’ve updated to a new mac and also Mantid v.6.7. I don’t seem to be able to search the data archive when using the indirect data reduction interface.

I get “invalid runs” instead of the ‘run’ button. I have “Search data archive” set as default (ISIS only). Switching to ‘All’ does not help. Is there a drive I need to mount or similar?

I have just tried on IDaaS using OSIRIS 56954 and it worked ok. @Ian when was this not working? It may be related to the network issues at site.

It’s not been working for as long as I’ve been using 6.7.
The archive is available on IDaaS, but I can’t get it to work on my local Mantid.

You may need to manually mount the archive on macOS to get it to function properly.
The instructions are given here: Getting Started

Thanks Conor, I’ve mounted the network drive, but it still is not working as expected.

I’ve tried adding /Volumes/inst$/ manually as a search directory, but it isn’t finding files from a simple run number in the reduction interface. I can browse to the raw files on the mounted volume so the connection seems fine.

I’m having a deeper look into this. As far as I can tell, it’s getting the linux path to search with rather than the macOS one. I’ll see if there’s a replacement step that’s being missed out somewhere. Have you had it work properly on macOS in the past? Just to know if this is a regression

@Ian I’ve had a look into the issue and it’s due to the path that gets returned when we query the archive for the location (the one we get back is designed for the archive mount on linux, which isn’t compatible with macOS since Catalina). I have posted a fix that will work with the default macOS mounting, which will be available in the nightly when it gets merged.

In the meantime though, there is this as a workaround (which you’ll need administrator privileges for):

  • Open Terminal

  • cd /etc/

  • sudo vim synthetic.conf

  • Press I to enable ‘Insert’ mode.

  • Add this:

    archive	Volumes/inst$ 

    on the first line. (Make sure the space is a tab character, by copying the line)

  • Press escape to exit ‘Insert’ mode and type :wq and press enter to save and quit

  • Reboot, after which the archive should begin working as expected.

To be honest I’m not sure if this has ever worked. I’ve just recently switched from a mac to a pc in the office. I’ve used Mantid on mac at home, though I think used local files or VNC to log in to an on-site PC.